Resolved- Mylab ,Mastering and Pearson+

Incident

Resolved- Mylab ,Mastering and Pearson+

Status: Closed
Start:
End:
Duration: 19 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We are investigating an issue with MyLab and Mastering. As a result, customers may see an Unable to login error message when attempting to login to site. We will update you in the next 60minutes as more information is provided.

Update

We have identified the problem with  MyLab, Mastering and Pearson+. We are working to implement a solution and will update you with new information once it becomes available.

Update

We have confirmed a technical issue that may impact your MyLab , Mastering and Pearson+ courses. Some customers may be unable to login to site. Teams are working to resolve this issue. We sincerely apologize for any inconvenience.

Resolved

Services are now restored to being healthy and stable. Thank you for your patience as we worked to resolve this issue.