Resolved- Mylab ,Mastering and pearson+
Resolved- Mylab ,Mastering and pearson+
2026-05-08T06:08:00.0000000Z
2026-05-08T06:08:00.0000000Z
We're getting customer reporting that users are receiving an error message when attempting to Login site. We are working to restore services and will update you within the next hour.
2026-05-08T06:16:00.0000000Z
2026-05-08T06:16:00.0000000Z
We have identified the problem with Mylab, mastering and Pearson+. We are working to implement a solution and will update you with new information once it becomes available.
2026-05-08T06:23:00.0000000Z
2026-05-08T06:23:00.0000000Z
We have confirmed a technical issue that may impact your Mylab, mastering and Pearson+ courses. Some customers may be unable to login.Teams are working to resolve this issue. We sincerely apologize for any inconvenience.
2026-05-08T06:28:00.0000000Z
2026-05-08T06:28:00.0000000Z
Services are now restored to being healthy and stable. Thank you for your patience as we worked to resolve this issue.