Scheduled Maintenance: Revel & MLM

Maintenance

Scheduled Maintenance: Revel & MLM

Status: Closed
Start:
End:
Duration: 30 days 2 hours 33 minutes
Affected Components:
Higher Education Courseware Revel
Update

We are performing system maintenance on Tuesday, May 5th from 11am EST to 12pm EST. During this time, {{ Incident.ComponentsByName }} content will be either degraded or unavailable.

Resolved

Services are now restored to being healthy and stable. Thank you for your patience as we worked to resolve this issue.