Degraded Performance: Revel & MLM
Incident
2026-06-03T15:13:00.0000000Z
Degraded Performance: Revel & MLM
Status: Closed
Start:
2026-05-04T12:35:00.0000000Z
End:
2026-06-03T15:13:00.0000000Z
Duration: 30 days 2 hours 38 minutes
Affected Components:
Higher Education Courseware
Revel
Update
2026-05-04T12:35:00.0000000Z
2026-05-04T12:35:00.0000000Z
We're getting customer reports that they cannot login. We are working to restore services and will update you within the next hour.
Resolved
2026-06-03T15:13:00.0000000Z
2026-06-03T15:13:00.0000000Z
We have concluded the maintenance event. Thank you for your patience as we completed this update.