Degraded Performance: Mastering & Revel

Incident

Degraded Performance: Mastering & Revel

Status: In Progress
Start:
Affected Components:
Higher Education Courseware Mastering Revel
Update

We're getting customer reports that some users are unable to login. We are working to restore services and will update you within the next hour.

Update

We have confirmed a technical issue that may impact customers to login. We apologize for the inconvenience while we work to resolve the issue and will update you when new information becomes available.

Update

Teams have made significant progress toward resolving the issue, but some users may still be experiencing login issues. We apologize for the inconvenience and will provide an update as more information becomes available.