Degraded Performance: NAVVY

Incident

Degraded Performance: NAVVY

Status: Closed
Start:
End:
Duration: 3 minutes
Affected Components:
School Assesments NAVVY
Update

We've identified an issue affecting customer's ability to login. We appreciate your patience as we work to resolve this issue.

Resolved

Services remain healthy and stable, and the issue is now resolved.