Logins Unavailable

Incident

Logins Unavailable

Status: Closed
Start:
End:
Duration: 29 minutes
Affected Components:
Higher Education Courseware Revel
Update

We're getting customer reports that they cannot login. We are working to restore services and will update you in 60 minutes. 

Update

We have confirmed a technical issue that may impact customers' (what can't they do?). We apologize for the inconvenience while we work to resolve the issue. We will update you when new information becomes available.

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.