MyLabs and Mastering and Pearson+ Login is Unavailable

Incident

MyLabs and Mastering and Pearson+ Login is Unavailable

Status: Closed
Start:
End:
Duration: 16 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We are investigating an issue with your MyLab and Mastering sign-in. As a result, customers may see the following error message when attempting to log in: Unable to login, Please contact administrator. We will update you in the next 60 minutes with more information.

Update

We have confirmed a technical issue with log in is impacting MyLab and Mastering and Pearson+ users. We apologize for the inconvenience while we work to resolve the issue. We will update you when new information becomes available.

Update

Teams have made significant progress toward resolving the issue, but some users may still be experiencing an error message when attempting to log in . We apologize for the inconvenience and will update you in 1 hour.

Resolved

Services remain healthy and stable, and the issue is now resolved.