Resolved: MyLab, Mastering, and Pearson+ Courses Inaccessible

Incident

Resolved: MyLab, Mastering, and Pearson+ Courses Inaccessible

Status: Closed
Start:
End:
Duration: 14 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We are investigating an issue with course sign-in. As a result, customers may see an error message when attempting to login. We will update you in the next 60 minutes with more information.

Update

We apologize for the technical issue impacting course logins. Technology teams are engaged and working to restore services: we appreciate your patience and will provide an update when new information becomes available. 


Resolved

We appreciate your patience while we addressed this issue. This incident is now resolved.