Resolved - MyLab, Mastering and Pearson+

Incident

Resolved - MyLab, Mastering and Pearson+

Status: Closed
Start:
End:
Duration: 1 hour 29 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We're getting customer reports that they cannot login to the site and receiving an error message. We are working to restore services and will update you in 60 minutes. 

Update

We have confirmed a technical issue that may impact customers all the services are completely down ATMWe apologize for the inconvenience while we work to resolve the issue. We will update you when new information becomes available.

Update

We have confirmed a technical issue that may impact your course(s). Some customers may be unable to access MLM products and Pearson +. Teams are working on resolving this issue; we apologize for any inconvenience. 

Resolved

Services remain healthy and stable, and the issue is now resolved.