Resolved - MyLab, Mastering and Pearson+

Incident

Resolved - MyLab, Mastering and Pearson+

Status: Closed
Start:
End:
Duration: 23 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We are investigating an issue with login issues to MyLab and Mastering. As a result, customers may be unable to access when attempting to login. We will update you in the next 60 minutes with more information.

Update

We have confirmed a technical issue that is impacting customers while accessing MyLab, Mastering and Pearson+. We apologize for the inconvenience while we work to resolve the issue. We will update you when new information becomes available.

Update

We have identified the problem with MyLab, Mastering and Pearson+. We have implemented a solution and will update you with new information once it becomes available.  

Resolved

We appreciate your patience while we addressed this issue. This incident is now resolved.