RESOLVED: Logins available for MyLab, Mastering, and Pearson+ Courses
RESOLVED: Logins available for MyLab, Mastering, and Pearson+ Courses
2025-10-27T15:11:00.0000000Z
2025-10-27T15:11:00.0000000Z
We are investigating an issue with course access. As a result, customers may see an error message when attempting to login. We will update you in the next 60 minutes with more information.
2025-10-27T15:16:00.0000000Z
2025-10-27T15:16:00.0000000Z
We have confirmed a technical issue that may impact your courses. Some customers may be unable to login. Teams are working on resolving this issue; we apologize for any inconvenience.
2025-10-27T15:20:00.0000000Z
2025-10-27T15:20:00.0000000Z
We apologize for the technical issue impacting your ability to login. Technology teams are engaged and working to restore services: we appreciate your patience and will provide an update when new information becomes available.
2025-10-27T15:24:00.0000000Z
2025-10-27T15:24:00.0000000Z
Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.