Pearson+, MyLab and Mastering is Unavailable

Incident

Pearson+, MyLab and Mastering is Unavailable

Status: Closed
Start:
End:
Duration: 2 hours 5 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We are investigating an issue with sign-in. As a result, customers may see an  error message when attempting to log into the site.   We will update you in the next 60 minutes with more information.

Update

We have confirmed a technical issue that may impact Pearson+ and MyLab and Mastering customers' preventing users from logging into their site. We apologize for the inconvenience while we work to resolve the issue. We will update you when new information becomes available.

Update

Teams have made significant progress toward resolving the issue, but some users may still be experiencing an error when logging into their site . We apologize for the inconvenience and will update you in 1 hour.

Resolved

Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.