RESOLVED: MyLab Mastering and Pearson plus access issue

Incident

RESOLVED: MyLab Mastering and Pearson plus access issue

Status: Closed
Start:
End:
Duration: 27 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

We have received reports of Mylab and Mastering are currently unavailable and are experiencing an "Unable to log in, Please contact administrator" We are working to resolve the issue and will update you in 60 minutes. 

Update

We apologize for the technical issue impacting MyLab, Mastering and Pearson Plus. Technology teams are engaged and working to restore services: we appreciate your patience and will provide an update when new information becomes available. 


Update

Teams have made significant progress toward resolving the issue, but some users may still be experiencing issues accessing MyLab, Mastering and Pearson Plus. We apologize for the inconvenience and will update when more information is available


Resolved

Systems are fully operational, and we have resolved this incident. We appreciate your patience as we worked to address the issue.