Issue affecting NOVAS and Review360 has been resolved

Incident

Issue affecting NOVAS and Review360 has been resolved

Status: Closed
Start:
End:
Duration: 20 minutes
Affected Components:
Clinical Assessments UK Teaching and Awarding Review360 Novas
Update

Some customers are reporting that they cannot access Novas and receive the error message "Unable to login. Please contact administrator". We are working to restore services and will update you in 60 minutes.

Update

We have confirmed a technical issue that may impact Novas and Review360 services. Some customers may receive the error message "Unable to login. Please contact administrator". Teams are working on resolving this issue; we apologize for any inconvenience.

Update

We apologize for the technical issue impacting your Novas and Review360 services. Services are beginning to recover. Technology teams are currently monitoring the environment to ensure stability. We appreciate your patience and will provide an update when new information becomes available.

Resolved

We appreciate your patience while we addressed the issue affecting Novas and Review360. This incident is now resolved.