Degraded Performance
Incident
2025-03-21T15:05:00.0000000Z
Degraded Performance
Status: Closed
Start:
2025-02-06T16:59:00.0000000Z
End:
2025-03-21T15:05:00.0000000Z
Duration: 42 days 22 hours 6 minutes
Affected Components:
Higher Education Courseware
Mastering
MyLab
Pearson +
Update
2025-02-06T16:59:00.0000000Z
2025-02-06T16:59:00.0000000Z
We're getting customer reports that they cannot (what are they trying to do?). We are working to restore services and will update you in 60 minutes.
Resolved
2025-03-21T15:05:00.0000000Z
2025-03-21T15:05:00.0000000Z
We have concluded the maintenance event. Thanks for your patience as we completed this update.