Degraded Performance

Incident

Degraded Performance

Status: Closed
Start:
End:
Duration: 11 minutes
Affected Components:
Higher Education Courseware Mastering MyLab Pearson +
Update

Test 3: We're getting customer reports that they cannot (what are they trying to do?). We are working to restore services and will update you in 60 minutes. 

Update

Update 2:

Resolved

Services remain healthy and stable, and the issue is now resolved.