Degraded Performance
Incident
2024-05-21T14:13:00.0000000Z
Degraded Performance
Status: Closed
Start:
2024-05-21T14:09:00.0000000Z
End:
2024-05-21T14:13:00.0000000Z
Duration: 4 minutes
Affected Components:
English Language Learning
MyEnglishLab (MEL)
Pearson English Connect (PEC)
Pearson English Portal (PEP)
Update
2024-05-21T14:09:00.0000000Z
2024-05-21T14:09:00.0000000Z
We're getting customer reports that they cannot sign in. We are working to restore services and will update you in 60 minutes.
Resolved
2024-05-21T14:13:00.0000000Z
2024-05-21T14:13:00.0000000Z