Maintenance

Maintenance

Maintenance

Status: Closed
Start:
End:
Duration: 10 minutes
Affected Components:
English Language Learning Higher Education Courseware Clinical Assessments UK Teaching and Awarding AimswebPlus English Benchmark Young Learners (EBYL) Learning Catalytics ATP (NNAT-3, TELL, GRADE, GMADE) Mastering MyEnglishLab (MEL) Keystone (DRA-3/EDL-2, Write to Learn) Pearson English Connect (PEC) Q-Global MyLab Pearson English Portal (PEP) Q-Interactive Pearson English Portal App Pearson Interactive Labs Review360 Pearson + Pearson Practice English (PPE) App Work Sampling Online Revel Reader+ / eBook / eText Test Hub StatCrunch Versant International Certificate (PTE General) Readiness Test Level Test Benchmark Test
Update

Clinical Assessments, English Language Learning, Higher Education Courseware, Pearson +, Test Services, Workforce Solutions is under maintenance. During this time, access will be unavailable. 

Resolved

We have concluded the maintenance event. Thanks for your patience as we completed this update.